https - connection not private, https://www - all ok


Sorry if same question already asked many times.

I have web-server OpenLiteSpeed 1.4.50. SSL certificate from Let's Encrypt.

Virtual Host Example > Rewrite > Rewrite Rule
RewriteCond %{HTTP_HOST} !^www\. [NC]
RewriteRule ^ https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteCond %{HTTPS} off
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
Redirect from,, to work fine and browser shows SSL is good. But when I type it shows - connection not private. I have no idea why? Why SSL works for not work for What setting should i check?
Can you set the certificate tu support both......
I'm sorry, but how?
I think it is only one path for each certificate in Listener Defaultssl > SSL > SSL Private Key & Certificate

Yes, I have for https:// - Certificate name mismatch. How to set certificate to support and ?

I fixed it with
certbot -d -d
Threre were two unconnected/independent SSL certificate, one for, second for When I tried connect to, browser shows error - "Certificate name mismatch, because it issued for". This certbot command above extend/connect these two certificate and it works for and www. and etc. I hope I did everything right :)
Last edited: