I can't build OpenLitespeed 1.7.16

#1
I run build.sh file and return this error. I can't install it. Please help me!

OS is Linux, APP_MGR_CMD is dnf.
Last metadata expiration check: 1:22:49 ago on Tue 15 Nov 2022 08:44:33 PM +07.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 1:22:49 ago on Tue 15 Nov 2022 08:44:33 PM +07.
Package epel-release-9-4.el9.noarch is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Rocky Linux release 9.0 (Blue Onyx)
Last metadata expiration check: 1:22:50 ago on Tue 15 Nov 2022 08:44:33 PM +07.
Dependencies resolved.
===============================================================================================================================================================================
Package Architecture Version Repository Size
===============================================================================================================================================================================
Installing Groups:
Development Tools

Transaction Summary
===============================================================================================================================================================================

Complete!
Last metadata expiration check: 1:22:51 ago on Tue 15 Nov 2022 08:44:33 PM +07.
Package git-2.31.1-2.el9.2.x86_64 is already installed.
Package cmake-3.20.2-7.el9.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 1:22:52 ago on Tue 15 Nov 2022 08:44:33 PM +07.
Package git-2.31.1-2.el9.2.x86_64 is already installed.
Package cmake-3.20.2-7.el9.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
cmake installed.
Last metadata expiration check: 1:22:52 ago on Tue 15 Nov 2022 08:44:33 PM +07.
Package libtool-2.4.6-45.el9.x86_64 is already installed.
Package autoconf-2.69-38.el9.noarch is already installed.
No match for argument: autoheader
Package automake-1.16.2-6.el9.noarch is already installed.
Package wget-1.21.1-7.el9.x86_64 is already installed.
Package patch-2.7.6-16.el9.x86_64 is already installed.
Error: Unable to find a match: autoheader
liblsquic
Need to git download the submodule ...
Cloning into 'lsquic'...
remote: Enumerating objects: 7290, done.
remote: Counting objects: 100% (461/461), done.
remote: Compressing objects: 100% (352/352), done.
remote: Total 7290 (delta 134), reused 359 (delta 108), pack-reused 6829
Receiving objects: 100% (7290/7290), 8.75 MiB | 15.72 MiB/s, done.
Resolving deltas: 100% (5406/5406), done.
LIBQUICVER is 0a4f8953dc92dd3085e48ed90f293f052cff8427
Note: switching to '0a4f8953dc92dd3085e48ed90f293f052cff8427'.

You are in 'detached HEAD' state. You can look around, make experimental
changes and commit them, and you can discard any commits you make in this
state without impacting any branches by switching back to a branch.

If you want to create a new branch to retain commits you create, you may
do so (now or later) by using -c with the switch command. Example:

git switch -c <new-branch-name>

Or undo this operation with:

git switch -

Turn off this advice by setting config variable advice.detachedHead to false

HEAD is now at 0a4f895 Release 3.1.1
Submodule 'src/liblsquic/ls-qpack' (https://github.com/litespeedtech/ls-qpack) registered for path 'src/liblsquic/ls-qpack'
Submodule 'src/lshpack' (https://github.com/litespeedtech/ls-hpack) registered for path 'src/lshpack'
Cloning into '/root/ols/openlitespeed-1.7.16/lsquic/src/liblsquic/ls-qpack'...
Cloning into '/root/ols/openlitespeed-1.7.16/lsquic/src/lshpack'...
Submodule path 'src/liblsquic/ls-qpack': checked out 'ecccd9193f1ed94e496aeedd76fd1dc0cc3b4c02'
Submodule path 'src/lshpack': checked out '14bec45020023db299b0a2c12a0c9ac90fbed49b'
CMake Deprecation Warning at CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at CMakeModules/common.cmake:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.
Call Stack (most recent call first):
CMakeLists.txt:5 (INCLUDE)


CMake Deprecation Warning at src/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/adns/CMakeLists.txt:2 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/edio/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at CMakeModules/common.cmake:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.
Call Stack (most recent call first):
src/edio/CMakeLists.txt:2 (INCLUDE)


CMake Deprecation Warning at src/extensions/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/extensions/fcgi/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/extensions/cgi/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/extensions/jk/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/extensions/proxy/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/extensions/registry/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/extensions/lsapi/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/http/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/log4cxx/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/lsiapi/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/lsr/CMakeLists.txt:2 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/main/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/modules/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/modules/modgzip/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/modules/cache/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/modules/modreqparser/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/modules/modinspector/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/modules/uploadprogress/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/modules/pagespeed/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/quic/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/shm/CMakeLists.txt:2 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/socket/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at CMakeModules/common.cmake:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.
Call Stack (most recent call first):
src/socket/CMakeLists.txt:2 (INCLUDE)


CMake Deprecation Warning at src/spdy/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/sslpp/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/ssi/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/thread/CMakeLists.txt:2 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/util/CMakeLists.txt:2 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at src/h2/CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


-- Configuring done
-- Generating done
-- Build files have been written to: /root/ols/openlitespeed-1.7.16/build
Consolidate compiler generated dependencies of target lsr
Consolidate compiler generated dependencies of target edio
Consolidate compiler generated dependencies of target log4cxx
Consolidate compiler generated dependencies of target util
[ 8%] Built target log4cxx
[ 8%] Built target edio
[ 15%] Built target lsr
[ 28%] Built target util
Consolidate compiler generated dependencies of target h2
Consolidate compiler generated dependencies of target adns
Consolidate compiler generated dependencies of target lsshm
Consolidate compiler generated dependencies of target extensions
[ 28%] Built target adns
[ 30%] Built target h2
[ 33%] Built target extensions
[ 35%] Built target lsshm
Consolidate compiler generated dependencies of target fcgi
Consolidate compiler generated dependencies of target cgi
Consolidate compiler generated dependencies of target jk
Consolidate compiler generated dependencies of target proxy
[ 36%] Built target jk
[ 39%] Built target cgi
[ 40%] Built target proxy
[ 41%] Built target fcgi
Consolidate compiler generated dependencies of target registry
Consolidate compiler generated dependencies of target lsapi
Consolidate compiler generated dependencies of target lsquic
[ 42%] Built target registry
Consolidate compiler generated dependencies of target http
[ 43%] Built target lsapi
Consolidate compiler generated dependencies of target lsiapi
[ 44%] Building C object src/liblsquic/CMakeFiles/lsquic.dir/lsquic_enc_sess_ietf.c.o
Consolidate compiler generated dependencies of target main
[ 49%] Built target lsiapi
[ 63%] Built target http
[ 65%] Built target main
[ 65%] Building C object src/liblsquic/CMakeFiles/lsquic.dir/lsquic_engine.c.o
Consolidate compiler generated dependencies of target modgzip
Consolidate compiler generated dependencies of target cache
[ 65%] Built target modgzip
[ 67%] Built target cache
Consolidate compiler generated dependencies of target quic
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:88:14: error: unknown type name ‘SSL_QUIC_METHOD’
88 | static const SSL_QUIC_METHOD cry_quic_method;
| ^~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: In function ‘maybe_create_SSL_SESSION’:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:769:19: error: too many arguments to function ‘SSL_SESSION_from_bytes’
769 | ssl_session = SSL_SESSION_from_bytes(ticket_buf, ticket_sz, ssl_ctx);
| ^~~~~~~~~~~~~~~~~~~~~~
In file included from /root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:19:
/usr/include/openssl/ssl.h:1477:29: note: declared here
1477 | OPENSSL_EXPORT SSL_SESSION *SSL_SESSION_from_bytes(const uint8_t *in,
| ^~~~~~~~~~~~~~~~~~~~~~
Consolidate compiler generated dependencies of target socket
[ 68%] Built target quic
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:776:9: warning: implicit declaration of function ‘SSL_SESSION_early_data_capable’ [-Wimplicit-function-declaration]
776 | if (SSL_SESSION_early_data_capable(ssl_session))
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Consolidate compiler generated dependencies of target spdy
[ 70%] Built target socket
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: In function ‘iquic_esfi_create_client’:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:908:9: warning: implicit declaration of function ‘SSL_CTX_set_min_proto_version’; did you mean ‘SSL_CTX_set_min_version’? [-Wimplicit-function-declaration]
908 | SSL_CTX_set_min_proto_version(ssl_ctx, TLS1_3_VERSION);
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
| SSL_CTX_set_min_version
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:908:48: error: ‘TLS1_3_VERSION’ undeclared (first use in this function); did you mean ‘TLS1_2_VERSION’?
908 | SSL_CTX_set_min_proto_version(ssl_ctx, TLS1_3_VERSION);
| ^~~~~~~~~~~~~~
| TLS1_2_VERSION
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:908:48: note: each undeclared identifier is reported only once for each function it appears in
[ 71%] Built target spdy
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:909:9: warning: implicit declaration of function ‘SSL_CTX_set_max_proto_version’; did you mean ‘SSL_CTX_set_max_version’? [-Wimplicit-function-declaration]
909 | SSL_CTX_set_max_proto_version(ssl_ctx, TLS1_3_VERSION);
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
| SSL_CTX_set_max_version
Consolidate compiler generated dependencies of target sslpp
Consolidate compiler generated dependencies of target ssi
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:917:13: warning: implicit declaration of function ‘SSL_CTX_set_custom_verify’; did you mean ‘SSL_CTX_set_verify’? [-Wimplicit-function-declaration]
917 | SSL_CTX_set_custom_verify(ssl_ctx, SSL_VERIFY_PEER,
| ^~~~~~~~~~~~~~~~~~~~~~~~~
| SSL_CTX_set_verify
[ 71%] Building CXX object src/sslpp/CMakeFiles/sslpp.dir/sslengine.cpp.o
[ 71%] Building CXX object src/ssi/CMakeFiles/ssi.dir/__/http/requestvars.cpp.o
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:919:9: warning: implicit declaration of function ‘SSL_CTX_set_early_data_enabled’ [-Wimplicit-function-declaration]
919 | SSL_CTX_set_early_data_enabled(ssl_ctx, 1);
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:940:14: warning: implicit declaration of function ‘SSL_set_quic_transport_params’ [-Wimplicit-function-declaration]
940 | if (1 != SSL_set_quic_transport_params(enc_sess->esi_ssl, trans_params,
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:948:11: warning: implicit declaration of function ‘SSL_set_quic_method’; did you mean ‘SSL_set_ssl_method’? [-Wimplicit-function-declaration]
948 | if (!(SSL_set_quic_method(enc_sess->esi_ssl, &cry_quic_method)))
| ^~~~~~~~~~~~~~~~~~~
| SSL_set_ssl_method
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: In function ‘setup_handshake_keys’:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1145:5: warning: implicit declaration of function ‘HKDF_extract’ [-Wimplicit-function-declaration]
1145 | HKDF_extract(hsk_secret, &hsk_secret_sz, md, cid->idbuf, cid->len,
| ^~~~~~~~~~~~
[ 71%] Building CXX object src/sslpp/CMakeFiles/sslpp.dir/sslcert.cpp.o
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: At top level:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1248:1: error: return type is an incomplete type
1248 | verify_server_cert_callback (SSL *ssl, uint8_t *out_alert)
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1248:1: error: conflicting types for ‘verify_server_cert_callback’; have ‘void(SSL *, uint8_t *)’ {aka ‘void(struct ssl_st *, unsigned char *)’}
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:112:1: note: previous declaration of ‘verify_server_cert_callback’ with type ‘enum ssl_verify_result_t(SSL *, uint8_t *)’ {aka ‘enum ssl_verify_result_t(struct ssl_st *, unsigned char *)’}
112 | verify_server_cert_callback (SSL *, uint8_t *out_alert);
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: In function ‘verify_server_cert_callback’:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1259:16: error: ‘ssl_verify_invalid’ undeclared (first use in this function)
1259 | return ssl_verify_invalid;
| ^~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1259:16: warning: ‘return’ with a value, in function returning void [-Wreturn-type]
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1248:1: note: declared here
1248 | verify_server_cert_callback (SSL *ssl, uint8_t *out_alert)
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1267:25: error: ‘ssl_verify_ok’ undeclared (first use in this function)
1267 | return s == 0 ? ssl_verify_ok : ssl_verify_invalid;
| ^~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1267:16: warning: ‘return’ with a value, in function returning void [-Wreturn-type]
1267 | return s == 0 ? ssl_verify_ok : ssl_verify_invalid;
| ^
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1248:1: note: declared here
1248 | verify_server_cert_callback (SSL *ssl, uint8_t *out_alert)
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1270:16: warning: ‘return’ with a value, in function returning void [-Wreturn-type]
1270 | return ssl_verify_ok;
| ^~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1248:1: note: declared here
1248 | verify_server_cert_callback (SSL *ssl, uint8_t *out_alert)
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: In function ‘iquic_lookup_cert’:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1318:61: error: ‘SSL_OP_NO_TLSv1_3’ undeclared (first use in this function); did you mean ‘SSL_OP_NO_TLSv1_1’?
1318 | SSL_CTX_get_options(ssl_ctx) & ~SSL_OP_NO_TLSv1_3);
| ^~~~~~~~~~~~~~~~~
| SSL_OP_NO_TLSv1_1
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: In function ‘iquic_esfi_init_server’:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1405:10: warning: implicit declaration of function ‘SSL_set_quic_early_data_context’ [-Wimplicit-function-declaration]
1405 | if (!SSL_set_quic_early_data_context(enc_sess->esi_ssl,
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1426:42: error: ‘SSL_OP_NO_TLSv1_3’ undeclared (first use in this function); did you mean ‘SSL_OP_NO_TLSv1_1’?
1426 | SSL_clear_options(enc_sess->esi_ssl, SSL_OP_NO_TLSv1_3);
| ^~~~~~~~~~~~~~~~~
| SSL_OP_NO_TLSv1_1
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: In function ‘iquic_ssl_sess_to_resume_info’:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1467:5: warning: implicit declaration of function ‘SSL_get_peer_quic_transport_params’ [-Wimplicit-function-declaration]
1467 | SSL_get_peer_quic_transport_params(ssl, &trapa_buf, &trapa_sz);
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: In function ‘iquic_esfi_handshake’:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1917:14: error: ‘SSL_ERROR_EARLY_DATA_REJECTED’ undeclared (first use in this function)
1917 | case SSL_ERROR_EARLY_DATA_REJECTED:
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1919:13: warning: implicit declaration of function ‘SSL_reset_early_data_reject’ [-Wimplicit-function-declaration]
1919 | SSL_reset_early_data_reject(enc_sess->esi_ssl);
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~
[ 71%] Building CXX object src/sslpp/CMakeFiles/sslpp.dir/sslcertcomp.cpp.o
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1933:9: warning: implicit declaration of function ‘SSL_in_early_data’ [-Wimplicit-function-declaration]
1933 | if (SSL_in_early_data(enc_sess->esi_ssl))
| ^~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: In function ‘iquic_esfi_post_handshake’:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:1978:9: warning: implicit declaration of function ‘SSL_process_quic_post_handshake’ [-Wimplicit-function-declaration]
1978 | s = SSL_process_quic_post_handshake(enc_sess->esi_ssl);
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: In function ‘iquic_esf_get_server_cert_chain’:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2531:50: error: ‘sk_X509_call_copy_func’ undeclared (first use in this function); did you mean ‘sk_X509_set_cmp_func’?
2531 | sk_deep_copy((const _STACK *) chain, sk_X509_call_copy_func,
| ^~~~~~~~~~~~~~~~~~~~~~
| sk_X509_set_cmp_func
/root/ols/openlitespeed-1.7.16/src/sslpp/sslcertcomp.cpp:41:10: fatal error: openssl/pool.h: No such file or directory
41 | #include <openssl/pool.h>
| ^~~~~~~~~~~~~~~~
compilation terminated.
make[2]: *** [src/sslpp/CMakeFiles/sslpp.dir/build.make:118: src/sslpp/CMakeFiles/sslpp.dir/sslcertcomp.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:1416: src/sslpp/CMakeFiles/sslpp.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2532:28: error: ‘sk_X509_call_free_func’ undeclared (first use in this function); did you mean ‘sk_X509_set_cmp_func’?
2532 | copy_X509, sk_X509_call_free_func, (void(*)(void*))X509_free);
| ^~~~~~~~~~~~~~~~~~~~~~
| sk_X509_set_cmp_func
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2532:17: warning: passing argument 3 of ‘sk_deep_copy’ from incompatible pointer type [-Wincompatible-pointer-types]
2532 | copy_X509, sk_X509_call_free_func, (void(*)(void*))X509_free);
| ^~~~~~~~~
| |
| void * (*)(void *)
In file included from /usr/include/openssl/ex_data.h:114,
from /usr/include/openssl/bio.h:66,
from /usr/include/openssl/ssl.h:147,
from /root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:19:
/usr/include/openssl/stack.h:288:44: note: expected ‘void (*)(void *)’ but argument is of type ‘void * (*)(void *)’
288 | void (*free_func)(void *));
| ~~~~~~~^~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2531:13: error: too many arguments to function ‘sk_deep_copy’
2531 | sk_deep_copy((const _STACK *) chain, sk_X509_call_copy_func,
| ^~~~~~~~~~~~
In file included from /usr/include/openssl/ex_data.h:114,
from /usr/include/openssl/bio.h:66,
from /usr/include/openssl/ssl.h:147,
from /root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:19:
/usr/include/openssl/stack.h:286:24: note: declared here
286 | OPENSSL_EXPORT _STACK *sk_deep_copy(const _STACK *sk,
| ^~~~~~~~~~~~
[ 71%] Building C object src/liblsquic/CMakeFiles/lsquic.dir/lsquic_ev_log.c.o
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: In function ‘iquic_esfi_data_in’:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2700:9: warning: implicit declaration of function ‘SSL_provide_quic_data’ [-Wimplicit-function-declaration]
2700 | s = SSL_provide_quic_data(enc_sess->esi_ssl,
| ^~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2701:23: error: conversion to incomplete type
2701 | (enum ssl_encryption_level_t) enc_level, buf, len);
| ^~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: At top level:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2845:11: error: ‘ssl_encryption_initial’ undeclared here (not in a function)
2845 | (int) ssl_encryption_initial == (int) ENC_LEV_CLEAR &&
| ^~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2846:11: error: ‘ssl_encryption_early_data’ undeclared here (not in a function)
2846 | (int) ssl_encryption_early_data == (int) ENC_LEV_EARLY &&
| ^~~~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2847:11: error: ‘ssl_encryption_handshake’ undeclared here (not in a function)
2847 | (int) ssl_encryption_handshake == (int) ENC_LEV_INIT &&
| ^~~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2848:11: error: ‘ssl_encryption_application’ undeclared here (not in a function)
2848 | (int) ssl_encryption_application == (int) ENC_LEV_FORW ? 1 : -1];
| ^~~~~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2851:28: warning: ‘enum ssl_encryption_level_t’ declared inside parameter list will not be visible outside of this definition or declaration
2851 | set_secret (SSL *ssl, enum ssl_encryption_level_t level,
| ^~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2851:51: error: parameter 2 (‘level’) has incomplete type
2851 | set_secret (SSL *ssl, enum ssl_encryption_level_t level,
| ~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: In function ‘set_secret’:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2883:13: warning: implicit declaration of function ‘SSL_send_fatal_alert’ [-Wimplicit-function-declaration]
2883 | SSL_send_fatal_alert(ssl, ALERT_NO_APPLICATION_PROTOCOL);
| ^~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: At top level:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2983:40: warning: ‘enum ssl_encryption_level_t’ declared inside parameter list will not be visible outside of this definition or declaration
2983 | cry_sm_set_read_secret (SSL *ssl, enum ssl_encryption_level_t level,
| ^~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2983:63: error: parameter 2 (‘level’) has incomplete type
2983 | cry_sm_set_read_secret (SSL *ssl, enum ssl_encryption_level_t level,
| ~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2991:41: warning: ‘enum ssl_encryption_level_t’ declared inside parameter list will not be visible outside of this definition or declaration
2991 | cry_sm_set_write_secret (SSL *ssl, enum ssl_encryption_level_t level,
| ^~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2991:64: error: parameter 2 (‘level’) has incomplete type
2991 | cry_sm_set_write_secret (SSL *ssl, enum ssl_encryption_level_t level,
| ~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2999:38: warning: ‘enum ssl_encryption_level_t’ declared inside parameter list will not be visible outside of this definition or declaration
2999 | cry_sm_write_message (SSL *ssl, enum ssl_encryption_level_t level,
| ^~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2999:61: error: parameter 2 (‘level’) has incomplete type
2999 | cry_sm_write_message (SSL *ssl, enum ssl_encryption_level_t level,
| ~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3078:35: warning: ‘enum ssl_encryption_level_t’ declared inside parameter list will not be visible outside of this definition or declaration
3078 | cry_sm_send_alert (SSL *ssl, enum ssl_encryption_level_t level, uint8_t alert)
| ^~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3078:58: error: parameter 2 (‘level’) has incomplete type
3078 | cry_sm_send_alert (SSL *ssl, enum ssl_encryption_level_t level, uint8_t alert)
| ~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3093:14: error: unknown type name ‘SSL_QUIC_METHOD’
3093 | static const SSL_QUIC_METHOD cry_quic_method =
| ^~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3095:5: error: field name not in record or union initializer
3095 | .set_read_secret = cry_sm_set_read_secret,
| ^
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3095:5: note: (near initialization for ‘cry_quic_method’)
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3095:31: warning: initialization of ‘int’ from ‘int (*)()’ makes integer from pointer without a cast [-Wint-conversion]
3095 | .set_read_secret = cry_sm_set_read_secret,
| ^~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3095:31: note: (near initialization for ‘cry_quic_method’)
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3095:31: error: initializer element is not computable at load time
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3095:31: note: (near initialization for ‘cry_quic_method’)
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3096:5: error: field name not in record or union initializer
3096 | .set_write_secret = cry_sm_set_write_secret,
| ^
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3096:5: note: (near initialization for ‘cry_quic_method’)
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3096:31: warning: excess elements in scalar initializer
3096 | .set_write_secret = cry_sm_set_write_secret,
| ^~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3096:31: note: (near initialization for ‘cry_quic_method’)
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3097:5: error: field name not in record or union initializer
3097 | .add_handshake_data = cry_sm_write_message,
| ^
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3097:5: note: (near initialization for ‘cry_quic_method’)
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3097:31: warning: excess elements in scalar initializer
3097 | .add_handshake_data = cry_sm_write_message,
| ^~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3097:31: note: (near initialization for ‘cry_quic_method’)
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3098:5: error: field name not in record or union initializer
3098 | .flush_flight = cry_sm_flush_flight,
| ^
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3098:5: note: (near initialization for ‘cry_quic_method’)
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3098:31: warning: excess elements in scalar initializer
3098 | .flush_flight = cry_sm_flush_flight,
| ^~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3098:31: note: (near initialization for ‘cry_quic_method’)
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3099:5: error: field name not in record or union initializer
3099 | .send_alert = cry_sm_send_alert,
| ^
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3099:5: note: (near initialization for ‘cry_quic_method’)
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3099:31: warning: excess elements in scalar initializer
3099 | .send_alert = cry_sm_send_alert,
| ^~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3099:31: note: (near initialization for ‘cry_quic_method’)
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: In function ‘readf_cb’:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:3212:23: error: conversion to incomplete type
3212 | (enum ssl_encryption_level_t) readf_ctx->enc_level, buf, len);
| ^~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: At top level:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:112:1: warning: ‘verify_server_cert_callback’ used but never defined
112 | verify_server_cert_callback (SSL *, uint8_t *out_alert);
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c: In function ‘iquic_esf_get_server_cert_chain’:
/root/ols/openlitespeed-1.7.16/src/liblsquic/lsquic_enc_sess_ietf.c:2536:1: warning: control reaches end of non-void function [-Wreturn-type]
2536 | }
| ^
make[2]: *** [src/liblsquic/CMakeFiles/lsquic.dir/build.make:333: src/liblsquic/CMakeFiles/lsquic.dir/lsquic_enc_sess_ietf.c.o] Error 1
make[2]: *** Waiting for unfinished jobs....
[ 72%] Linking CXX static library libssi.a
make[1]: *** [CMakeFiles/Makefile2:1026: src/liblsquic/CMakeFiles/lsquic.dir/all] Error 2
[ 73%] Built target ssi
make: *** [Makefile:136: all] Error 2
cp: cannot stat 'build/src/openlitespeed': No such file or directory
cp: cannot stat 'build/src/modules/modreqparser/*.so': No such file or directory
cp: cannot stat 'build/src/modules/modinspector/*.so': No such file or directory
cp: cannot stat 'build/src/modules/uploadprogress/*.so': No such file or directory
Start to pack files.
mv: cannot stat 'dist/install.sh': No such file or directory
Building finished, please run ./install.sh for installation.
You may want to update the ols.conf to change the settings before installation.
Enjoy.
 
#7
Hi,
It's not really yet. To answer your question, install lsphp81 from the console, setup php8 external app, and switch the version from web admin > handler. Yes admin has lsphp7 build-in.
 
Top