LiteSpeed Cache


New Member
Not sure if OLS Forums is the right place for LiteSpeed cache, but here I go :D

I rebuilt the server again using as I was getting the below when activating the plugin, and it seems it does it on a fresh installation.


I installed as root, under my sudo user after using sudo su. The .htaccess file doesn't exist on a fresh installation, and the permissions are below.


Again, all new installation I have yet to change anything. On the old server creating the .htaccess file and entering the codes, it didn't fix the issue. I also set the wordpress directory to 777. I thought I broke this initially when I upgraded WP to 6.3, but apparently not :/


New Member
This is the exact command I ran for installation as well:

wget && bash --wordpressplus


New Member
I think, you must create .htaccess and add to it at beginning corresponding lines.
I did that on the first server I made and no dice. I will do it again real quick.

Here is my directory prior to me doing anything.


I added the below to /usr/local/lsws/wordpress/.htaccess

Deactivated the plugin. Activated the plug in and now I get this.


I will do it again and copy that new stuff to .htaccess


Deactivate -> Activate -> And...


You see where this goes. The loop never ends...

Might also note again that this is a brand new installation on debian 11. It has the outta the box stuff, vim, sudo, ssh, and OLS. As far as WP, the only plug in enabled is LS Cache. The others that are installed are the 2 default ones. WP is on 6.3


The WordPress folder and files' permission are incorrect.
The following list is my test site that I just freshly installed on a Ubuntu 22.04 server.
    1  wget && bash --wordpressplus
    2  ls -al /usr/local/lsws/wordpress/

total 252
drwxr-xr-x  5 nobody nogroup  4096 Aug 10 01:36 .
drwxr-xr-x 25 root   root     4096 Aug 10 01:07 ..
-rw-r--r--  1 nobody nogroup  1118 Aug 10 01:36 .htaccess
-rw-r--r--  1 nobody nogroup   186 Aug 10 01:36 .htaccess.bk
-rw-r--r--  1 nobody nogroup   405 Aug 10 01:07 index.php
-rw-r--r--  1 nobody nogroup 19915 Aug 10 01:07 license.txt
-rw-r--r--  1 nobody nogroup  7399 Aug 10 01:07 readme.html
-rw-r--r--  1 nobody nogroup  7211 Aug 10 01:07 wp-activate.php
drwxr-xr-x  9 nobody nogroup  4096 Aug 10 01:07 wp-admin
-rw-r--r--  1 nobody nogroup   351 Aug 10 01:07 wp-blog-header.php
-rw-r--r--  1 nobody nogroup  2323 Aug 10 01:07 wp-comments-post.php
-rw-r--r--  1 nobody nogroup  3013 Aug 10 01:07 wp-config-sample.php
-rw-r--r--  1 nobody nogroup  3416 Aug 10 01:36 wp-config.php
drwxr-xr-x  6 nobody nogroup  4096 Aug 10 01:07 wp-content
-rw-r--r--  1 nobody nogroup  5638 Aug 10 01:07 wp-cron.php
drwxr-xr-x 27 nobody nogroup 16384 Aug 10 01:07 wp-includes
-rw-r--r--  1 nobody nogroup  2502 Aug 10 01:07 wp-links-opml.php
-rw-r--r--  1 nobody nogroup  3927 Aug 10 01:07 wp-load.php
-rw-r--r--  1 nobody nogroup 49441 Aug 10 01:07 wp-login.php
-rw-r--r--  1 nobody nogroup  8537 Aug 10 01:07 wp-mail.php
-rw-r--r--  1 nobody nogroup 25602 Aug 10 01:07 wp-settings.php
-rw-r--r--  1 nobody nogroup 34385 Aug 10 01:07 wp-signup.php
-rw-r--r--  1 nobody nogroup  4885 Aug 10 01:07 wp-trackback.php
-rw-r--r--  1 nobody nogroup  3236 Aug 10 01:07 xmlrpc.php

May I know which OS you are using?
By the way, I will update the MariaDB setup function today.


No problem, but I am not sure why yours has the permission issue :unsure:
If it happens again, let me know, and I will try it on a Debian 11 server.