phpmyadmin not working in Google Cloud's openlitespeed-wordpress Image

#1
https://35.188.134.67/phpmyadmin/ works fine on fresh install from here https://console.cloud.google.com/marketplace/details/gc-image-pub/openlitespeed-wordpress
but after step three phpmyadmin not working.

I deleted and installed image multiple times and phpmyadmin working till adding ssl sertificate to domain. After I give"y" for "Do you wish to update the system which include the web server? [Y/n]" phpmyadmin redirects to redirects to this - https://35.188.134.67/phpmyadmin// and shows This page isn’t working

I also tried without adding domain name by giving "Ctr+C" at the beginning and phpmyadmin working till I update system by these commands - sudo apt update and sudo apt upgrade.
 
#2
Hi @Naveen Dsouza,

I can see the issue, you must hit the context level external redirect error. As you can see there's an extra / in the end of the url which is not right.
This issue should has been fixed on 1.5.9, https://openlitespeed.org/release-log/version-1-5-x/
`apt-get upgrade openlitespeed` should helps. You can also visit web admin>virtual host > context and update `/phpmyadmin/` to `/phpmyadmin` to make it work.

Please also test it on incognito browser to avoid any browser cache. Let us know if it works.

Best,
Eric
 
#3
Hi @Cold-Egg

` sudo apt-get upgrade openlitespeed` gave me "openlitespeed is already the newest version (1.5.10-1+bionic)"
Then I updated `/phpmyadmin/` to `/phpmyadmin`
I entered username as "root" and password which I get from `sudo cat /home/ubuntu/.db_password`
now phpmyadmin shows
"Cannot log in to the MySQL server "
"mysqli::real_connect(): (HY000/1698): Access denied for user 'root'@'localhost' "

now lsws pid shows LSWS PID3880
 
Last edited:
#5
Yes phpmyadmin can access now thank you for your help and mariadb is working but there are some warning in mariadb status. I also tried to add another domain as per these instructions but it is not worked. So I think there are many things are wrong after system update. I will delete this instance and deploy new openlitespeed-wordpress image and I will transfer my few blogs and install ssl certificate before doing system update. Then I will take backup of that instance and I will do system update and let you know if there are any problems after system update.
 
#6
#7
For phpmyadmin today also same problem it is redirecting to double slash after url then I changed as per your instruction and it worked. Apart from this everything is fine. There are total 35 packages for upgrade including mariadb so I think its better to release a new image version with all latest package version.

yes using script to create virtual host is easier, today I added virtual host using scripts.
second method in scripts gave me this error - "/bin/bash: /dev/fd/63: No such file or directory"

I want to install openlitespeed-wordpress image in Ubuntu 18.04 lts minimal can I get all scripts to install all softwares that are in openlitespeed-wordpress image
 
#14
Could you please try any of the following way ?

1. run it as :
Code:
sudo su -c "sh <(curl -sk https://raw.githubusercontent.com/litespeedtech/ls-cloud-image/master/Setup/vhsetup.sh)"

2. run following codes

Code:
wget https://raw.githubusercontent.com/litespeedtech/ls-cloud-image/master/Setup/vhsetup.sh
chmod +x vhsetup.sh
sudo ./vhsetup.sh
3. run

Code:
sudo su -
sh <(curl -sk https://raw.githubusercontent.com/litespeedtech/ls-cloud-image/master/Setup/vhsetup.sh)

You do not need run them all , by my estimation , any of them should work , please let us know how it goes.
 
#15
Hi Isqtwrk
Earlier I told that "yes using script to create virtual host is easier, today I added virtual host using scripts.". Which means I created virtual hosts using first method in Interactive mode. In your instruction No.2
I also tried to add virtual hosts using second method that is without downloading it. But that second method in Interactive mode not worked. Its not a problem for me I just informed.
I also tried to add virtual hosts using CLI mode. In CLI mode also first method worked second method not worked.

Coming to your instructions No.1& No.3 returned "/dev/fd/63: 238: /dev/fd/63: Syntax error: "(" unexpected (expecting "then")"
In creating virtual hosts I don't do any more tests as using scripts is easy way and there are many method to create virtual host using scripts and out of those methods two methods worked for me others are not worked thanks for your instructions.
 
#17
As per this report LiteSpeed is the fastest growing web server and if anyone search for "wordpress" in Google cloud's marketplace then openlitespeed-wordpress image is at first position. Now OpenLiteSpeed released version 1.5.11 but your openlitespeed-wordpress image in Google Cloud has version 1.5.9. Please release a new image version with a fix to phpmyadmin hitting context level external redirect error upon system upgrade.
 
Last edited:
#18
Hello, Naveen.

We plan to renew our images with 1.6.x once it is stable. In the meantime, if you install a new image, it will ask if you'd like to upgrade. So, even though the image is for 1.5.9, you will be given an opportunity to update to 1.5.11.

If you've already installed the image, you can use the lsup.sh script to update the server: https://openlitespeed.org/kb/how-to-upgrade-openlitespeed/#Method_4_New_lsupsh_script

Hope this helps!
 
Top