QUIC won't start, saying "Not support [quicenable 1]"

#1
I've tested it on both Ubuntu 18.4 and CentOS 6.6. Installed from repo, same thing from the binary. Installed good certificate, HTTP/2 works ok. I tried setting QUIC "On" on all three places (Server Tuning, Listener, Virtual Host) and still no udp listener activated, just admin (7080) and TCP 443.
The log says - when I enable QUIC on the server level: WARN [PlainConf] [tuning:] Not support [quicenable 1] in file /usr/local/lsws/conf/httpd_config.conf:65
I would appreciate any advice.

And let's say I somehow manage to make it work. Which particular browser is able to speak to the latest OpenLiteSpeed quic/HTTP/3 implementation?
 
#3
I don't have a slightest clue what I've done, but I somehow managed to make the udp:443 to show up. I checked quic and http/3 on all levels I could find, but it's still using HTTP/2 all the time. Not sure if ols doesn't like my browser or there is something else I am suppposed to explicitely enable (I do use Canary build and I've checked ssl1.2 and 1.3).
 
#4
I was on 78.0.3904.70 x64

if you have site failed connected , Chrome may not try to QUIC it again in certain period.

You can clean browser cache , and go to chrome://net-internals , flush all sockets and restart Chrome and try again.

be aware that QUIC requires UDP 443 in/out open on both sides, and you will need to have a valid cert (lets encrypt) ought do it.
 
#5
So - it seems it worked out now. Still, as I was trying to alter several settings at the same time, I am not 100% sure what went right. However, I am happy it woks now, so I can go further with my research.
Thank you
 
#6
So - it seems it worked out now. Still, as I was trying to alter several settings at the same time, I am not 100% sure what went right. However, I am happy it woks now, so I can go further with my research.
Thank you
basically the default QUIC conf should fit most situation
 
Top