SSL Error after update v1.6.7

#1
After update v 1.6.7, I've got error with SSL, server auto send self sign cert even I config everything (I've used Let's Encrypt and everything work well before update)

My log when update:
[root@trehoatinh openlitespeed]# ./install.sh
Openlitespeed web server exists, will upgrade.
INSTALL_TYPE is upgrade
Cannot find RUBY installation, remember to fix up the ruby path configuration
before you can use our easy RubyOnRails setup.

Target_Dir:/usr/local/lsws User:nobody Group:nobody
Admin:admin Password: AdminSSL:yes ADMIN_PORT:7080
LSINSTALL_DIR:/root/openlitespeed
TEMP_DIR:/tmp/lshttpd PID_FILE:/tmp/lshttpd/lshttpd.pid

Installing, please wait...

Admin SSL enabled!
download comamnd is wget -nv -O
2020-01-31 12:27:49 URL:http://cyberpanel.sh/?ip [15/15] -> "/usr/local/lsws/myip" [1]
openssl: error while loading shared libraries: libssl.so.1.1: cannot open shared object file: No such file or directory
SSL host is [webadmin], use adminSSL
groupadd: group 'lsadm' already exists
useradd: user 'lsadm' already exists
download comamnd is wget -nv -O
admin_php found and mv to admin_php.bak
2020-01-31 12:27:53 URL:http://www.litespeedtech.com/packages/lsphp5_bin/x86_64/lsphp5 [4902224/4902224] -> "/usr/local/lsws/admin/fcgi-bin/admin_php" [1]
admin_php downloaded.
[OK] lshttpd.service has been successfully installed!
Updating webcache manager, please waiting ...
Downloading latest shared code tar file...
Checking tar file md5...
Removing existing shared code directory...
Extracting downloaded shared code...
Removing local shared code tar file...
Updating lscmctl script...
Done!

Installation finished, Enjoy!

Your webAdmin password not changed.

Is my update ok ? I try to update openssl from 1.0.2 to 1.1.1 (newest) to try fix this bug but don't know how :)
My site: lamant.store
 
#2
You needn't to upgrade your openssl.
Actually openlitespeed is using BoringSSL. That error message is from wget, it is all right, not a big issue.
Do you have any issue while running the web server now?
 
#3
You needn't to upgrade your openssl.
Actually openlitespeed is using BoringSSL. That error message is from wget, it is all right, not a big issue.
Do you have any issue while running the web server now?
I change to use cloudflare SSL and it's ok now, but if I change back to use let's encrypt then got error NET::ERR_CERT_AUTHORITY_INVALID
 

Cold-Egg

Administrator
#7
Hi, config looks fine on listener. Can you share a screenshot on virtual host> XXX > ssl tab? Maybe you have a self-signed cert rewrite it.
 
Top