Bug in Litespeed cache plugin

Hello everyone,
Hope you all are good. After spending too much time with litespeed i was able to figure out slow loading speed of my sites. Now they are pretty cool and loading fast. i.e https://mazahub.com/ and lunchtimeresult.com
But i recently purchased new domain
I have setted up it same way as i figured out in previous sites that disabling wordpress cron helps and enable server level cron. With litespeed crawler enabled. But here i am facing issue when ever i update or posted new post same issue started happening.
I am getting same x-litespeed-cache: miss header
So i started troubleshooting and came to know that litespeed crawler is scheduled according to server configurations. But issue is this that new cache should be taken as previous cache is purged but nothing is happening like this.
I tried to disable purge functionality as a whole but still nothing is helping.
Thanks in advance

I do see x-litespeed-cache hit header , do you still have problem to get it cached or any other issue ?

Best regards,
I can also see these header but once a new post is drafted or published on this site. @lsqtwrk Please read my above post properly. Because i have defined everything is working but last time slowness of my site was caused due to just a simple things that crawlers was not running properly and i disabled wordpress cron and run system cron that caused my sites load faster but https://cheapoakleyvaultsunglasses.com/ this site is dynamic and updated daily or even after 10 minutes. So issue is with this site. Is there any way to run crawler after each cache purge. I disabled purge but still cache is being purged.