Custom DocumentRoot returns 404

I created a new virtual host for a domain name say, with the custom Document Root (/home/someName/html) having just one index.html page. The owner and group of the document root folder is the domain name without the extension (someName:someName). I have specified "someName" in the Run as User as well as the Run as Group option in the (virtual host level) External App > LiteSpeed SAPI configuration page.

OpenLiteSpeed returns a 404 error message when trying to access this domain. What is causing this and how can I fix it?


The virtual host has the following configuration:

Virtual Host Name someName
Virtual Host Root
Config File $SERVER_ROOT/conf/vhosts/$VH_NAME/vhconf.conf
Follow Symbolic Link Yes
Enable Scripts/ExtApps Yes
Restrained Yes
External App Set UID Mode DocRoot UID

Document Root /home/someName/html
Domain Name
Enable GZIP Compression Yes
Index Files:
Use Server Index Files No
Index Files index.html, index.php
Last edited:
Not sure if this is related to the issue or not but I ran `tail -f /usr/local/lsws/logs/error.log` and the following five lines keep popping up every few minutes:

[NOTICE] [428017] [AdminPHP] add child process pid: 432468
[NOTICE] [428017] sendKillCmdToWatchdog: 'extappkill:432468:-3:0'.
[NOTICE] [428013] Cmd from child: [extappkill:432468:-3:0]
[INFO] [428013] Failed to get process [432468] start time, not running, skip killing.
[NOTICE] [428017] [LocalWorker::workerExec] Config[AdminPHP]: suExec uid -1 gid -1 cmd /usr/local/lsws/admin/fcgi-bin/admin_php -c ../conf/php.ini, final uid 999 gid 65534, flags: 0.
Last edited:


New Member
One thing that I came across is that you also have to add the virtual host to the listener which is super annoying and doesn't make much sense but it caught me off since it is not in the instructions.