DigitalOcean Wordpress IonCube is Missing

#1
After installing AliDropship Woo Plugin I got an error
Ooops! ionCube Loader Not found.

Can you add some compatibility in the future updates please? Currently I'll uninstall it, cause I can't find anything related to "How to install IonCube on Openlitespeed DigitalOcean Wordpress" in Google. The closest to my thread is this
https://www.litespeedtech.com/support/forum/threads/solved-how-to-install-ioncube.5503/

But it's kinda old and out of date. Don't wanna experiment.
 

Attachments

Cold-Egg

Administrator
#2
Hi @lateralus578 ,

The image didn't come with all PHP extensions installed by default.
You can simply install it by
Code:
apt-get install lsphp73-ioncube -y
Feel free to change the 73 to other php version you may have.

best,
Eric
 
#3
Thanks :)
It worked, everything is fine. :) :)

After running this command to install IonCube, I also went to admin panel and restarted the system.

For those who're reading:
Visit https://use_your_droplet_ip:7080 to access WebAdmin in a browser and simply click "Perform Graceful Restart". This will restart the system and ioncube notification in WP-Admin will disappear. :)
 
#5
Hi, I installed the extension using:
apt-get install lsphp73-ioncube -y, and performed a restart, still it would show ioncube loader not found.
 
#10
Hello There @Cold-Egg I'm trying to re-open this thread again :) Can you help me out please? ionCube thingy again. Image attached.

1. After I install plugin > Fatal Error > ionCube issue
2. Visited this thread, command here: apt-get install lsphp73-ioncube -y I don't think that command line (haven't tried that one yet) will work, cause I followed instructions in documentation and updated my PHP to 7.4.

3. I did like this: apt-get install lsphp74-ioncube -y
It returns: Unable to locate package lsphp74-ioncube

Question:
How do I install ionCube on DigitalOcean OpenLiteSpeed Droplet with PHP 7.4?
 

Attachments

#11
I hope I'm wrong, but from what I could gather in Google > PHP 7.4 doesn't support ioncube yet. That's why that command didn't work out? If it's true then...
If it's impossible to install ioncube on php 7.4 then how to reverse back to php 7.3 ?

I followed instructions in docs: https://docs.litespeedtech.com/cloud/wordpress/ to update to php 7.4
Step 1: WebAdmin console > Server Configuration > External App > Add > Type > LiteSpeed SAPI App
Step 2: WebAdmin console > Virtual Hosts > your vhost > Script Handler > Add

So, I ended up with working php7.4, in order to reverse to php7.3, I just need to delete those 2 steps (LiteSpeed SAPI App + Script Handler) and restart by typing command: killall -9 lsphpnew
Or there is more to that?
 

Attachments

Cold-Egg

Administrator
#12
Hi,

Right, the ioncube is not stable release so we did not provide it for the LSPHP74.

To revert back is easy, just change the Command from `/usr/local/lsws/lsphp74/bin/lsphp` to other PHP vinary version, and restart the PHP.
Let us know if it works.

Best,
Eric
 
Top