Openlightspeed is not working with Google Load Balancer

#1
Hi there,
I am new to OLS, I am OLS Cloud image Google Cloud platform. It's all working fine. But the issue is, OLS is not working with Google Load Balancer. Health check returning the unhealthy status of backend. Which I don't why?
As you know if server IP is given back 200 header response than health check should return healthy status. In my case, my server Ip (http://34.93.95.168/ ) is returning 200 header response, so normally Health Status should give back a healthy status.
Is there something that I am missing?

Thanx in advance,
Gagandeep

P.S. I always setup Load Balancer for all my websites, to use Google CDN
 
#2
Sorry. I do not use Google Load Balancer, so I do not know what exact issue is for openlitespeed.
can you give me more info, such as a what request should return 200, but openlitespeed response a non-200 error code?
For the healthy status about google, I think I don't know much.
 
#3
As I mentioned earlier that For Load Balancing to work, health check should return 200 response code and Openlightspeed server is returning the same response code. So under normal circumstances backend should be healthy.

AwesomeScreenshot-www-webconfs-http-header-check.php-2019-08-10_5_02.png
But Still, I don't know why backend is unhealthy. Moreover, there is only one instance in the backend. I m just using the Load balancer to enable the cloud CDN.
 

Cold-Egg

Administrator
#4
Hi @Gagandeep6895 ,

I tried and here's my LoadBalancer status result
Code:
Name                      Type           Zone       Healthy     Autoscaling   Balancing mode     Capacity
unmanage-instance-group-1 Instance group us-east4-a 1 / 1          Off        Max CPU: 80%       100%
No health check issue happens on my OpenLiteSpeed-WordPress instance launched from GCP marketplace.

FYI, health check parameters are using default values with TCP port 80

I probably am not qualified to help you to debug GCP health check issue but just show my test is ok. :)

Best
 
Last edited:
Top