PHPmyAdmin - file size exceeded the maximum size permitted by your PHP

#1
Hi,

First of all i need to say that i like OLS, im new, im coming from WHM Centos, this is my first experiment with wordpress/centos 7 because im looking for speed for low traffic websites.

I did the installation of OLS via "one click", everything works fine with a wordpress pre installed.

My problem is that i need to upload a new wordpress installation in the same place, so, i installed phpmyadmin and when im trying to upload a 3mb file it says:

No data was received to import. Either no file name was submitted, or the file size exceeded the maximum size permitted by your PHP configuration. See FAQ 1.16.

I know is about php.ini, so i edited the file at etc/php.ini, but the problem persist, i did a php --ini:

[root@centos-2gb-hel1-2 ~]# php --ini
Configuration File (php.ini) Path: /etc
Loaded Configuration File: /etc/php.ini
Scan for additional .ini files in: /etc/php.d
Additional .ini files parsed: /etc/php.d/curl.ini,
/etc/php.d/fileinfo.ini,
/etc/php.d/json.ini,
/etc/php.d/phar.ini,
/etc/php.d/zip.ini


There is no other php.ini!!!!!

Im doing something wrong?

this is my php.ini:

post_max_size = 128M
memory_limit = 512M
max_input_time = 300

I did restart OLS and server :)


Thanks
 
#5
Hi,

First of all i need to say that i like OLS, im new, im coming from WHM Centos, this is my first experiment with wordpress/centos 7 because im looking for speed for low traffic websites.

I did the installation of OLS via "one click", everything works fine with a wordpress pre installed.

My problem is that i need to upload a new wordpress installation in the same place, so, i installed phpmyadmin and when im trying to upload a 3mb file it says:

No data was received to import. Either no file name was submitted, or the file size exceeded the maximum size permitted by your PHP configuration. See FAQ 1.16.

I know is about php.ini, so i edited the file at etc/php.ini, but the problem persist, i did a php --ini:

[root@centos-2gb-hel1-2 ~]# php --ini
Configuration File (php.ini) Path: /etc
Loaded Configuration File: /etc/php.ini
Scan for additional .ini files in: /etc/php.d
Additional .ini files parsed: /etc/php.d/curl.ini,
/etc/php.d/fileinfo.ini,
/etc/php.d/json.ini,
/etc/php.d/phar.ini,
/etc/php.d/zip.ini


There is no other php.ini!!!!!

Im doing something wrong?

this is my php.ini:

post_max_size = 128M
memory_limit = 512M
max_input_time = 300

I did restart OLS and server :)


Thanks
In PHP.ini file add this code

upload_max_filesize = 128M
post_max_size = 25M
memory_limit = 512M

If you still having issues you can go through this guide to increase upload size limit
 
#6
The procedures above are complex and editing the .HTACCESS and WP-CONFIG files won't work because OLS has set your sever maximum upload file size on all your websites to 2MB.

However, it's easy to fix this. Login to your control panel then locae PHP >>> EDIT PHP CONFIGS on the SIDE MENU.
select php config.PNG

From here, select the PHP version on your WORDPRESS

edit.PNG

Once you select your PHP version scroll on the given options and locate UPLOAD MAX FILE SIZE and change the figure to any value then SAVE. By default it is set at 2MB
asdfsadfsafd.PNG

From there, select your website under LIST WEBSITES
list web.PNG

Then select MANAGE on the website that you wish to increase the upload size
sadfdsfsafsa.PNG


Then select CHANGE PHP and chose the PHP version on your WORDPRESS and save and it will effect on your Wordpress. That's all.
Captureasdfsadf.PNG
 
Top