Quic / http/3 not working in version 1.7.1 directadmin version

MEMT

New Member
#1
Hello,

I guess there is a bug in the 1.7.1 directadmin version.

I'm using CURRENT VERSION:OpenLiteSpeed (DirectAdmin Edition) 1.7.1
Running on Debian 10 - with DirectAdmin 1.61.2

https://forum.directadmin.com/threads/how-to-enable-quic.61136/

There is no way to get QUIC working in the 1.7.1 version, if you rollback to version 1.6.13 QUIC is working again.


Could this be a possible bug in the 1.7.1 version? Would be helpful if this could be fixed if it is.


Thank you, in advance.
 

MEMT

New Member
#3
Hello Pong,

Domain I send you by DM.

1. With this extension https://chrome.google.com/webstore/detail/http2-and-spdy-indicator/mpbpobfflnpcgagjijhmgnchggcjblin
2. https://gf.dev/http3-test
3. https://http3check.net/

I also send you a second site, of another person that had the same problem, and started a topic on the forum of directadmin
https://forum.directadmin.com/threads/how-to-enable-quic.61136/

I asked for his site as well. Before it didn't work, then he downgraded back to 1.6.13 and now QUIC is working on his site.

Please advise me if I should wait, to downgrade.

If you have any questions, please ask. I'm just moved from ngix to openlitespeed and would like to keep it.
One of the reasons was that it supposed to support QUIC ;)
 
#7
Same problem here with version 1.7.6.
Sometimes it is working but after some time it stop working.
The Quic Header is missing in http responses, but i can connect with netcat.
I use Wordpress with openlitespeed caching.
 
#11
Now, after some time i have the problems again.
I use Openlitespeed without directadmin.
A simple restart don't help but i have many warnings in the server logfile.
 
#13
Nevermind, totally forgot I had re-activated Cloudflare for now because I could not get http/3 to work reliably anyway. So in my case, Cloudflare is now the problem. Apologies for the mislead. Let me disable it and rerun.
 
#16
Is that a problem? This is added by the Cloudflare Wordpress plugin:
Code:
      // add header unconditionally so we can detect plugin is activated
      if (!is_user_logged_in() ) {
        header( 'cf-edge-cache: cache,platform=wordpress' );
      } else {
        header( 'cf-edge-cache: no-cache' );
      }
Meaning I don't think this has any effect. The server is clearly marked as LiteSpeed in the headers.
 

David

Active Member
#19
I tested your site with Chrome and it shows it is using H2. Base on your setting, it seems to be good for Http3.
I do not know the reason, you may create a ticket so that our support can help you.
Thanks
David
 
Top