Can't upgrade OpenLiteSpeed

Hello, I got an issue with OpenLiteSpeed, getting long response times and issues with cloudflare giving "error 524: a time out ocurred". I'm trying to update OpenLiteSpeed to see if that helps with the issue, but the server doesn't seems to be able to connect to the litespeed repositories.

When I run:

apt-get upgrade openlitespeed

I get the following error for every file:

Err:1 bionic/main amd64 lsphp70-common all 7.0.33-13+bionic
404 Not Found [IP: 80]

If I try to sign the key for the repo with (in verbose mode so it returns any information)

wget -vO - | sudo apt-key add -

The server returns the following error

ERROR: cannot verify's certificate, issued by ‘CN=server13’:
Self-signed certificate encountered.
ERROR: certificate common name ‘server13’ doesn't match requested host name ‘’.
To connect to insecurely, use `--no-check-certificate'.
gpg: no valid OpenPGP data found.

Oddly enough I ran a IP check through and the domain returns
IP Address:

But our server is trying to connect to IP: 80. When I ping to the server it does connect and get all the packages. If I open the domain in my local computer with the web browser it does open the repository.

I tried turning off the firewall and disabling every proxy, without any success.

Thanks a lot if anyone can help me with this issue, I'm running Ubuntu 18.04 and also got CyberPanel installed.


Do you have any hosts entries for The IP you that it is resolving to on your server is not one of our servers.

What is output of `iptables -L -t nat` and `ifconfig`
I posted the message on the forum some time ago, but it wasn't approved so I wrote to OpenLiteSpeed support by email, I was told to ran some commands over the terminal, with:

cat /etc/hosts

I got an entry on our hosts file with:

I deleted it and that solved the problem, but left me wondering what would had caused that entry to be there in the first place, I am the only administrator of this server, and haven't done such thing as redirecting the to that ip.

Any ideas?


I believe only you can figure out who can touch that /etc/hosts file and modified it. OLS won't do such override at all.