One Click WordPress installation not working on Vultr

I have tried 5 times to installed WordPress on new Vultr VPS but every time I am getting the following error.

Finished setting up WordPress.
Finished MySQL setup without error.
Trying to stop some web servers that may be using port 80.
[OK] litespeed: pid=4450.
Please be aware that your password was written to file '/usr/local/lsws/password '.
Congratulations! Installation finished.
Please access http ://localhost:80/ to finish setting up your WordPress site.
And also you may want to activate the LiteSpeed Cache plugin to get better performance.

Testing ...
OK: test webAdmin page passed.
OK: test Example vhost page passed.
Error: test wordpress HTTP first page failed.
Error: test wordpress HTTPS first page failed.

When I am accessing WordPress through IP I am getting error " The site is experiencing technical difficulties"

Can someone help on same?

PS: I have used the same one-click install on DigitalOcean, It is working there.
Last edited:


Hi @hardhatengineer ,

Thanks for the information. The one-click app on vultr is build/controlled by vultr team only, but we will give it a try and report the issue to them. :) You can also log a ticket to us via with the forum link appended if you want us to take a look on your environment directly.

Thanks for your answer.
I check log and error is as below;

[] [STDERR] PHP Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /usr/local/lsws/wordpress/wp-includes/wp-db.php:1645
Stack trace:
#0 /usr/local/lsws/wordpress/wp-includes/wp-db.php(639): wpdb->db_connect()
#1 /usr/local/lsws/wordpress/wp-includes/load.php(427): wpdb->__construct('olsdbuser', 'ZjgyODI1', 'olsdbname', 'localhost')
#2 /usr/local/lsws/wordpress/wp-settings.php(120): require_wp_db()
#3 /usr/local/lsws/wordpress/wp-config.php(90): require_once('/usr/local/lsws...')
#4 /usr/local/lsws/wordpress/wp-load.php(37): require_once('/usr/local/lsws...')
#5 /usr/local/lsws/wordpress/wp-blog-header.php(13): require_once('/usr/local/lsws...')
#6 /usr/local/lsws/wordpress/index.php(17): require('/usr/local/lsws...')
#7 {main}
thrown in /usr/local/lsws/wordpress/wp-includes/wp-db.php on line 1645

Can you please look into the same.



I just to clarify that you are talking about this ols 1 click instead of the app one-click like , right?

So this is what i found so far on vultr Ubuntu 18.04 server. Somehow there's no mysqli loaded and `/usr/local/lsws/lsphpxx/etc/php/x.x/mods-available/` is empty.

Same OS version and installation steps on DigitalOcean all works fine. Haven't fine out the root cause yet, but thanks for the bug report.



understood @hardhatengineer ,

It's something relate to the PHP with the platform on vultr.
Just tried install again with CentOS7 on Vultr and it works good.
Our php build engineer will back on next Monday and fix it, please wait for few days if you still need Ubuntu + Vultr.