Ubuntu 20.04 focal dependency issue with libzip4

I tried to install OpenLiteSpeed today on a fresh ubuntu 20.04 droplet on Digital Ocean as per https://openlitespeed.org/kb/install-ols-from-litespeed-repositories/

I can add the repo fine but when I try to do sudo apt install openlitespeed I get

openlitespeed : Depends: lsphp73 but it is not going to be installed

Then , I try sudo apt install lsphp73 to see what is wrong I get

lsphp73 : Depends: libzip4 (>= 1.0) but it is not installable

Again sudo apt install libzip4 and

E: Package 'libzip4' has no installation candidate

So, basically I don't see any way around this. I can't install libzip4 any other way since it need other unattainable packages. I tried 18.04 but then other packages created the conflict.

The thing is I was able to install it on a 20.04 just a couple of days ago.

Can anyone help me understand what this is about or maybe get me out of this mess. I'd really appreciate it. Cheers
Last edited:



It works for me.
    1  wget -O - http://rpms.litespeedtech.com/debian/enable_lst_debian_repo.sh | bash
    2  apt-get install openlitespeed
    3  service lsws status
Maybe you can try apt update && apt upgrade -y before the installation.
I did.
This is very weird. Can you check if libzip4 is installed. I looked into it and libzip4 isn't available on 20.04

I am so stumped I can't even speculate.
Ok. The issue was, as expected, on my part. What I thought was a fresh install was apparently not one. As I did sudo apt update to double check one of the repositories caught my eye. It was the bionic (18.04) repo. I had both bionic and focal (20.04) versions added.

The mystery is resolved from there on. It was trying to get the older version, thus required and older package.

Gotta love the community. I decided to sleep on it and someone else helped me druing. Cheers